Форум по программам «Инфокрафт» для ЖКХ

Форум GKHsoft.ru
Интеграция с ГИС ЖКХ!
База знаний Инфокрафт

Вопросы и ответы, рабочие инструкции, документация по решениям Инфокрафт.

Разбиение оплаты по секциям

Страницы: 1 2 След.
Разбиение оплаты по секциям, Разбиение оплаты по секциям
Добрый день!
Имеется конфигурация "Инфокрафт: ЖКХ. Бухгалтерия управляющей компании" проблема в том что мы используем несколько программ для приема платежей по мимо 1с тоесть для нас важно что бы каждая программа пробивала чек на фискальном регистраторе (FPrint 55k) в свой отдел (секцию) я зашел в документ "оплата услуг" и в "процедуре ОсновныеДействияФормыЧек(Кнопка)" изменил номер секции на нужный мне 4 но сумма продолжают идти в 1 отдел.

Где и что нужно изменить чтобы сумма оплаты шла в нужную секцию на фискально регистраторе???
Добрый день, Петр.

Попробуйте не вносить изменения в типовую конфигурацию (чтобы в дальнейшем не было проблем с обновлениями), обойтись изменениями в обработке обслуживания (процедура ПечататьСтроку()).
БАЗА ЗНАНИЙ ИНФОКРАФТ
Вопросы и ответы, рабочие инструкции, документация по решениям Инфокрафт.
Перейти в базу знаний
я не совсем понимаю как мне это поможет так как в этой процедуре нечего не сказано о секциях.
Шестой параметр в этой функции - Отдел.
Это и есть секция, о которой Вы говорите.
БАЗА ЗНАНИЙ ИНФОКРАФТ
Вопросы и ответы, рабочие инструкции, документация по решениям Инфокрафт.
Перейти в базу знаний
но я не понимаю что именно там нужно поменять чтобы чеки из документа оплаты шли в 4 отдел.
В обработке обслуживания в функции ПечататьСтроку() замените упоминание переменной Отдел на 4.
И используйте измененную обработку для печати.
БАЗА ЗНАНИЙ ИНФОКРАФТ
Вопросы и ответы, рабочие инструкции, документация по решениям Инфокрафт.
Перейти в базу знаний
Спасибо!!! завтра буду пробовать.
ничего не вышло. вот код может я не то смотрю




Функция ПечататьСтроку(Объект, Наименование, Количество, Цена, Скидка, Отдел, НДС, СуммаСоСкидкой = 0) Экспорт

Результат = мНетОшибки;

Если СуммаСоСкидкой = 0 Тогда
СуммаСоСкидкой = Окр(Количество * Цена * (1 - Скидка * 0.01), 2, РежимОкругления.Окр15как20);
КонецЕсли;

Если Не Объект.Драйвер.НапечататьФискСтроку(Объект.ИДУстройства, Наименование, Количество,
Цена, СуммаСоСкидкой, Отдел, НДС) Тогда
Результат = мОшибкаНеизвестно;
Объект.Драйвер.ПолучитьОшибку(Объект.ОписаниеОшибки);

ОтменитьЧек(Объект);
КонецЕсли;

Возврат Результат;

КонецФункции // ПечататьСтроку()
Добрый день, Петр.

Что именно не получилось?
Код зависит от обработки обслуживания - у каждой свой.
Вы заменили "Отдел" на 4?
Обработку обслуживания потом в информационной базе заменили?
БАЗА ЗНАНИЙ ИНФОКРАФТ
Вопросы и ответы, рабочие инструкции, документация по решениям Инфокрафт.
Перейти в базу знаний
если вы имеете ввиду заминить слово "отдел " на цифру "4" то

{ВнешняяОбработка.АТОЛФискальныеРегистраторы.МодульОбъекта(544,72)}: Ожидается имя формального параметра
Функция ПечататьСтроку(Объект, Наименование, Количество, Цена, Скидка, <<?>>4, НДС, СуммаСоСкидкой = 0) Экспорт (Проверка: Толстый клиент (обычное приложение))
Страницы: 1 2 След.
Вы уже с нами?
13 Посетителей на сайте
выбирают программу.
22630 Выбрали решения
Инфокрафт с 2004г.